DH miss 1 photo after mission upload in long missions

Did you see a mistake? Have you experienced an issue? Please tell us, so we can fix it.
audraudra
Posts: 5
Joined: Tue Mar 19, 2019 3:06 pm

DH miss 1 photo after mission upload in long missions

Post by audraudra » Tue Mar 19, 2019 3:43 pm

We have problem everytime we fly long missions: when we fly long missions, after a while drone starts hover and app shows at mission is uploading to drone. After upload drone starts to fly again but it misses to take one photo. It is very important issue for us because it is very important at drone takes all pictures. Same problem appeared both with DH Basic and DH Pro (trial version).
We use:
Panthom 4 Pro ver2 drone
Samsun SM-T820 tablet

App settings we use:
Top-Down mission,
Flight altitude 100m
Overlap: Horizontal 60%, vertical – 80%

Is it possible at that issue will be fixed?

Martin
Posts: 201
Joined: Wed Mar 28, 2018 4:47 pm

Re: DH miss 1 photo after mission upload in long missions

Post by Martin » Tue Mar 19, 2019 6:37 pm

audraudra wrote:
Tue Mar 19, 2019 3:43 pm
We have problem everytime we fly long missions: when we fly long missions, after a while drone starts hover and app shows at mission is uploading to drone. After upload drone starts to fly again but it misses to take one photo. It is very important issue for us because it is very important at drone takes all pictures. Same problem appeared both with DH Basic and DH Pro (trial version).
We use:
Panthom 4 Pro ver2 drone
Samsun SM-T820 tablet

App settings we use:
Top-Down mission,
Flight altitude 100m
Overlap: Horizontal 60%, vertical – 80%

Is it possible at that issue will be fixed?
Hello Audraudra,

Thank you for reporting this issue! The hovering and mission upload is always happening during long missions. DJI limits the number of waypoints that can be uploaded to the drone and thus we have to do long missions in batches.

With respect to missing image(s):
We will look into it. If we can reproduce the issue, it is likely a bug and from what you describe in terms of occurrence and symptoms it should then be possible to fix the underlying issue. If that's the case, we would also try to fix this with the next update. We also know that DJI had in the past firmware bugs that resulted in missing images, but the scenario you describe looks more like a systematic missing image after mission upload which we likely can fix.

Findings so far (work in progress):
  1. DJI normally reports back to DH when the camera successfully took an image. Unfortunately, this event is not always correctly triggered by DJI. As a result you will sometimes see missing media icons on the 2D map while the drone is flying (each correctly reported image, will get an image icon on the map at the location where the image was taken). Even though that image icon is missing, the camera could still have taken the image (check in media viewer the number of images and compare with the number of reported images).
    We are working on a workaround to still report the image recordings in such situations, even if DJI did not report it to us correctly.
  2. So far we did not have any real missing images on the sd card, just unreported ones. It still could be that it actually happens for you, and that's why I asked you for additional information in the post below. It can help us to reproduce the exact same setting you are flying in in order to understand what could be the issue for missing images.

Thanks again,
Martin

Martin
Posts: 201
Joined: Wed Mar 28, 2018 4:47 pm

Re: DH miss 1 photo after mission upload in long missions

Post by Martin » Wed Mar 20, 2019 11:39 am

audraudra wrote:
Tue Mar 19, 2019 3:43 pm
We have problem everytime we fly long missions: when we fly long missions, after a while drone starts hover and app shows at mission is uploading to drone. After upload drone starts to fly again but it misses to take one photo. It is very important issue for us because it is very important at drone takes all pictures. Same problem appeared both with DH Basic and DH Pro (trial version).
We use:
Panthom 4 Pro ver2 drone
Samsun SM-T820 tablet

App settings we use:
Top-Down mission,
Flight altitude 100m
Overlap: Horizontal 60%, vertical – 80%

Is it possible at that issue will be fixed?
Can you tell me
  1. Chosen Flight Speed during launch dialog?
  2. Chosen Recording mode during launch dialog? (precise images/stopping, precise images / not stopping, images every x seconds)?
  3. Are you shooting RAW, JPG, HDR?

audraudra
Posts: 5
Joined: Tue Mar 19, 2019 3:06 pm

Re: DH miss 1 photo after mission upload in long missions

Post by audraudra » Wed Mar 20, 2019 4:45 pm

Thank you for quick reaction.
We really miss photos - for example: mission info says that it will be 226 photos, we get only 224 photos. (See attached image)

Other answers:
1. Chosen Flight Speed during launch dialog? – I really do not remember that we specified something specific speed. I think we used some default setting. If it is important, I can try to find it.
2. Chosen Recording mode during launch dialog? - we chose: “precise images / not stopping
3. We are shooting JPG
Attachments
dh_pfotos_miss.PNG
dh_pfotos_miss.PNG (51.48 KiB) Viewed 810 times

Martin
Posts: 201
Joined: Wed Mar 28, 2018 4:47 pm

Re: DH miss 1 photo after mission upload in long missions

Post by Martin » Wed Mar 20, 2019 7:18 pm

audraudra wrote:
Wed Mar 20, 2019 4:45 pm
Thank you for quick reaction.
We really miss photos - for example: mission info says that it will be 226 photos, we get only 224 photos. (See attached image)

Other answers:
1. Chosen Flight Speed during launch dialog? – I really do not remember that we specified something specific speed. I think we used some default setting. If it is important, I can try to find it.
2. Chosen Recording mode during launch dialog? - we chose: “precise images / not stopping
3. We are shooting JPG
Perfect, thanks for that info. The speed can have influence as follows:
The drone camera takes some time to take an image and store it on the sd card (but for JPG this is usually pretty fast). In precise images / not stopping the drone continues to fly towards the next waypoint while its camera is taking the image. If the camera is by chance still busy when reaching the next waypoint, it can happen that it can't already trigger the next shot again.
Since you did shoot in jpg, it is unlikely that this was the cause and in addition, you also mentioned it happens after the upload of the next batch of waypoints. So please do not spend time looking up what speed you used.

We did our tests/investigations today mostly with stop & shoot mode, so we have to look into what happens in the not stopping mode. Will let you know here once we know more.

Thanks again for your feedback, which helps us in narrowing the problem cause down much faster.

Best regards,
Martin

audraudra
Posts: 5
Joined: Tue Mar 19, 2019 3:06 pm

Re: DH miss 1 photo after mission upload in long missions

Post by audraudra » Thu Mar 21, 2019 2:53 pm

It sounds greate! Thanks!

Best regards,
Audra

Martin
Posts: 201
Joined: Wed Mar 28, 2018 4:47 pm

Re: DH miss 1 photo after mission upload in long missions

Post by Martin » Mon Mar 25, 2019 9:29 am

audraudra wrote:
Thu Mar 21, 2019 2:53 pm
It sounds greate! Thanks!

Best regards,
Audra
Hi Audra,

Sorry to follow up again with another question:
When using Precise images / not stopping mode for recording images, one can select the camera triggering mode. What kind of camera triggering mode did you choose during the launch dialog?
  1. Distance based
  2. App based
We should soon have back our Phantom 4 for further tests (currently was in use for some inspection jobs).

audraudra
Posts: 5
Joined: Tue Mar 19, 2019 3:06 pm

Re: DH miss 1 photo after mission upload in long missions

Post by audraudra » Mon Mar 25, 2019 9:54 am

Hi,

Last time we have used "DIstance based".


//Audra

Levasco
Posts: 6
Joined: Tue Feb 26, 2019 3:48 pm

Re: DH miss 1 photo after mission upload in long missions

Post by Levasco » Wed Mar 27, 2019 8:39 am

Hi, just wanted to add that this is happening to me too. During long missions the drone will stop and pause while 'uploading mission' appears. When it restarts, it leaves a gap of one image in the grid.

I'm using
- Mavic 2 Pro
- Sony Xperia tablet
- Terrain top down missions with custom DEM
- 90% forward overlap
- Non-stopping flights, ~2 m/s

Thanks in advance!

Martin
Posts: 201
Joined: Wed Mar 28, 2018 4:47 pm

Re: DH miss 1 photo after mission upload in long missions

Post by Martin » Wed Mar 27, 2019 10:17 am

Levasco wrote:
Wed Mar 27, 2019 8:39 am
Hi, just wanted to add that this is happening to me too. During long missions the drone will stop and pause while 'uploading mission' appears. When it restarts, it leaves a gap of one image in the grid.

I'm using
- Mavic 2 Pro
- Sony Xperia tablet
- Terrain top down missions with custom DEM
- 90% forward overlap
- Non-stopping flights, ~2 m/s

Thanks in advance!
Thanks for letting me know. This confirms there is a minor bug which causes a miss of one image using the described recording modes. We are looking into it and will try to fix it with our next update.

Post Reply

Return to “Bug Reports”